Thursday, March 10, 2016

An interesting EMC tale..

I spent much of the last week doing EMC testing on a new NetBurner module, for FCC and CE qualification.  The basic process is you take a unit to the test lab and they do various emissions and immunity tests.  This happens with basically every electronic product you ever purchase.

This week we had an odd result that is worth of a write up...
Most EMC tests start with emissions testing as that is the most often failed part so get that done first.

One of the tests in the middle is Radiated Immunity...
For normal consumer products they put the unit in an RF field of about 3V per meter and sweep the frequency.  This test is done in a 3M RF chamber and in the place we test this is split into 16 parts....

Front, back,right, left  in each of vertical and horizontal polarity with two sweeps one up to 1Ghz and one from 1 Ghz to 2.7Ghz.   Your unit is supposed to remain operational during the test...
So for this new unit a Wifi /Ethernet to serial unit we put a loop back cable between the serial connections and do an ethernet ping and tcp over wifi loop back through the serial connection.
We monitor that data goes out and back and is reliable.  Running 2.4Ghz wifi we expect some packet loss when they sweep through 2.4Ghz, but the unit should recover.


The first 8 tests under 1Ghz were uneventful....
For over 1Ghz they swap out the drive antenna for a wide band horn and different amplifier.
The first 4 tests, left, right x horizontal,vertical all went well.

Then we started doing the front and back of the unit and the Wifi in the unit started acting flakey. It would loose the wifi connection and nothing I could do would make it come back. This was with the  chamber open and the signal turned off.  It seemed like physically moving the unit caused it to die.
I got through one more set, the back, leaving just the front of the unit to test and I just could not get it to work ,,,, So I aborted the testing on Tuesday and drove back to the office from the test lab in orange county.
Since moving the unit caused it to die I assumed a bad solder joint.
When I got back to the office I re-flowed the wifi module and and retested wifh while violently shaking the unit.  It worked flawlessly...

So I went back to the lab on Wednesday, EFT, surge, ESD, conducted immunity etc...
Everything worked flawlessly for the next two days. The WIFI was really solid....

This afternoon we had one test left >1Ghz radiated immunity to the front, horizontal and vertical...

The unit fired right up and worked flawlessly....
We finished the horizontal test, the drive was off no signal...
The test technician went into the chamber and rotated the drive horn from Horizontal to Vertical...
WIFI died. I rebooted the unit and nothing I did could make wifi work...
So I asked them to turn off their amplifier.... and the wifi  came back to life...
(This is with the drive to the AMP turned off)  Amp on wifi dead, amp off wifi works....

We then rotated the drive antenna back to horizontal and turned the amp on...
Wifi worked.... we rotated the  feed horn wifi died...

The strange part is when the tests were actually running IE they were driving RF energy in to the AMP and out the antenna at our unit WIFI worked flawlessly. It only died when the test set was idle.

The WIFI antenna on our unit could be rotated to vertical or horizontal, so as long as that antenna was  of opposite polarity to the test antenna everything worked....

What is even stranger is we could be dead and idle and turn on the test IE drive energy and things worked....

So we did the last test with the WIFI antenna horizontal..

The whole time our unit could scan for the WIFI router and recieve fine, when it tried to transmit things died...
So what is going on?  The only theory I have is that our WIFI signal was coupling into the amplifier and causing some king of feedback, ie like Microphone squeal...

The guys running the EMC lab have been doing this for 30 years and they have never seen anything like it... It was a strange Day...

5 comments:

Wolfkeeper said...

Not sure I completely understand exactly what 'died' meant, but WiFi works by only transmitting when nothing is being received, this avoids crapping all over other people's packets. It could be there's some bug being triggered when it's constantly receiving a signal and it's waiting to send, but never can get a word in.

Normally that wouldn't be triggered because WiFi signals are intermittent, so it may be an unusual test, although it should pass it nevertheless.

Andy said...

So the test lab's equipment didn't pass EMC test. ;)

богдан ян said...

I also enjoy reading the comments, but notice that a lot of people should stay on topic to try and add value to the original essay writing serivce blog post. I would also encourage everyone to bookmark this page to your favorite service to help spread the word. I'll use this information for my essay topics.

novelinflow said...

Technology Submission - State of the Art - Novel InFlow Tech - Featured Project Development;|/ ·1; Rotary-Turbo-InFlow Tech / - GEARTURBINE PROJECT Have the similar basic system of the Aeolipilie Heron Steam Turbine device from Alexandria 10-70 AD * With Retrodynamic = DextroRPM VS LevoInFlow + Ying Yang Way Power Type - Non Waste Looses *8X/Y Thermodynamic CYCLE Way Steps. 4 Turbos, Higher efficient percent. No blade erosion by sand & very low heat target signature Pat:197187IMPI MX Dic1991 Atypical Motor Engine Type. |/·2; Imploturbocompressor; One Moving Part System Excellence Design - The InFlow Interaction comes from Macro-Flow and goes to Micro-Flow by Implossion - Only One Compression Step; Inflow, Compression and outflow at one simple circular dynamic motion / New Concept. To see a Imploturbocompressor animation, is possible on a simple way, just to check an Hurricane Satellite view, and is the same implo inflow way nature.

heroineworshipper said...

Sounds like a job for a spectrum analyzer. The ubertooth has proven quite valuable for setting up these FCC tests at the day job.